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INTRODUCTION 

It has often been shown that the information obtained from aerial LiDAR6 surveys generates 
significant economic benefits for the forest industry and for several other Québec government 
activity sectors (Lebœuf et al., 20157). Nevertheless, the use of raw LiDAR data remains complex 
and requires extensive experience and advanced computing tools. To facilitate the use of this data 
and optimize the benefits of LiDAR data use, the ministère des Forêts, de la Faune et des Parcs 
(MFFP) has therefore generated and made available a range of user-friendly products derived 
from LiDAR data. 

   
The purpose of this document is therefore to: 

i) present the basic products derived from LiDAR data that are available as open source 
data;  

ii) explain the basic tools that facilitate their use in ArcGIS;  
iii) explain the basic tools that facilitate their use in QGIS; 
iv) present the tools that can be used to develop new derived products (e.g. generate 

contour lines, convert rasters to polygons, fill lakes, delimit drainage basins (watersheds), 
reclassify rasters, generate a focal CHM, generate a topographic wetness index, etc.). 

  

                                                           
6   LiDAR: Light Detection and Ranging. 
7 Available online: 
http://www.mffp.gouv.qc.ca/publications/forets/connaissances/Analyse_retombees_LiDAR-Finale.pdf. 

http://www.mffp.gouv.qc.ca/publications/forets/connaissances/Analyse_retombees_LiDAR-Finale.pdf
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1 LIDAR DERIVED PRODUCTS 

The four basic products derived from LiDAR data are the: 1) Digital Terrain Model (DTM), 
2) Hillshade (Shaded Relief), 3) Canopy Height Model and 4) Slope Model. These products are in 
raster format and can easily be viewed in most basic GIS software packages, including ArcGIS and 
QGIS.  

The following is a list of technical characteristics common to the four products presented in this 
document: 

Geodetic reference datum GRS 80 Ellipsoid 
Geodetic reference system NAD 83 SCRS 
Projection Modified Transverse Mercator (MTM) 
Production method Processed using Lastools, R, Gdal and ArcGIS 
Data-viewing software ArcGIS, QGIS, MapInfo, etc. 

 

1.1 DIGITAL TERRAIN MODEL (DTM) 
This raster file provides real numerical values representing 
altitudes in metres relative to the mean sea level. The raster file’s 
pixel elevation values correspond to the linear interpolation of the 
network of irregular triangles created from the ground points. The 
spatial resolution of this raster is 1 metre. 
 
The DTM is a basic product derived from LiDAR. It serves primarily 
to create the Hillshade and Slopes. It is also used for hydrological 
models, road construction, flood risk management, visual 
landscape analyses, and so on. 

 

  

1.2 HILLSHADE (SHADED RELIEF) 
This raster file simulates the three-dimensional appearance of a 
relief map. It therefore does not contain altitude values. Shadow 
and light are shades of grey associated with integers from 0 to 255 
(from black to white). The spatial resolution of this raster is 
2 metres. 
 
A hillshade presents a very detailed image of the terrain and can 
be used for the identification and interpretation of surficial 
deposits, drainage, wetlands, etc.  
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1.3 CANOPY HEIGHT MODEL (CHM) 
This raster file provides numerical values representing forest 
canopy heights or the heights of other raised elements (e.g. 
buildings). It corresponds to the difference between the digital 
surface model and the digital terrain model. The 
“MHC_nofeuillet.lyr” file represents a symbology (range of colours) 
for height in metres. The spatial resolution of this raster is 1 metre. 

The CHM can be used to measure height, density and stand structure, and to construct statistical 
relationships in order to map volumes, basal areas, etc.  

It should be noted that different elements must be taken into account before using the CHM to 
evaluate the height of trees or vegetation:  

 
1. Tree heights are generally slightly underestimated by LiDAR. The disparity is greater in 

coniferous forests than in deciduous forests. It is also greater when the point density is 
lower. For example, a study done in the “reserve faunique des Laurentides” showed an 
underestimation of -0.98 metres based on 431 tree measurements and a LiDAR datum 
with a density of 7.1 points/m2 (Sadeghi et al., 2016). On the other hand, given that 
several factors have to be taken into account (forest type, point density, forest cover, 
etc.), it is strongly suggested that users carry out their own field measurement 
campaigns to determine if any adjustments to the data set are necessary. 

 

2. The CHM can accurately determine the height of trees and vegetation. Based on the tops 
of fir and spruce trees, the CHM may initially make it appear that the crowns are much 
smaller in width than they actually are, because sometimes only one pixel, located on 
the highest point of the tree (e.g. 20 m), shows the actual height of the tree. The other 
surrounding pixels indicate lower values for the crowns (e.g. 15 m). 

 

3. Finally, it should be noted that a certain expertise is required to integrate tree heights 
derived from a CHM to forest stand polygons. It is necessary to take the local maxima 
(maximum height of each crown) from the CHM and choose from a multitude of 
calculation methods to integrate the various heights (example: 95 th percentile, modal 
height, etc.).   
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1.4 SLOPE MODEL (SLOPES) 
This raster file provides real numeric values representing 
slopes. The product is generated from the digital terrain 
model. The file “Pentes_nofeuillet.lyr” represents a 
symbology (range of colours) for slope classes: A [0 to 3 %], 
B ]83 to 8 %], C ]8 to 15 %], D ]15 to 30 %], E ]30 to 40 %], F ]40 to 
50 %], X1 ]50 to 70 %], X2 ]70 % and +].  

The slopes map can be used as a support tool for forest operations 
or roads construction. 

 

 

  

                                                           
8 The open bracket shows that the value is excluded from the class. 
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2 AVAILABILITY OF LIDAR DERIVED PRODUCTS 

The first areas benefiting from LiDAR derived products in 2016 were the Saguenay – Lac-Saint-
Jean region (UA 024-51), Mauricie region (UA 041-51) and the entire Outaouais region. In the 
following years, several other regions of Québec were also able to benefit from these products. 
LiDAR products are expected to be available for all of southern Québec by the end of 2022. For 
information on the areas for which products will be released in the future, please refer to the 
LiDAR product availability schedule at: 

https://mffp.gouv.qc.ca/forets/inventaire/pdf/Planification_LIDAR_produits_derives.pdf 

 

  

https://mffp.gouv.qc.ca/forets/inventaire/pdf/Planification_LIDAR_produits_derives.pdf
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3 ACCESS TO LIDAR DERIVED PRODUCTS 

LiDAR derived products are available free of charge and can be viewed or downloaded through 
three different ways. 

A) Through the Forêt ouverte interactive map, users can view different basic LiDAR products and 
download them free of charge. To do this: 

1. Access the interactive map: https://www.foretouverte.gouv.qc.ca; 
2. In the menu, click on the “Cartes prédéfinies (Map themes)” tab. 
3. Choose the “LiDAR” theme. 
4. View the layers of your choice by clicking on the eye (it must be green). 
5. If the eye next to a layer is grey, zoom in. 
6. To download LiDAR derived products, display the layer “LiDAR — Téléchargement (pleine 

qualité)” and click on the map sheet you wish to download.  
7. If layers are superimposed, select the “LiDAR — Téléchargement (pleine qualité)” layer in 

the new window that opens at the bottom of the screen.  
8. Select a product by clicking on the “Accéder” button. 

B) You can also view and download the data in a GIS (geographic information system) from the 
following Web map service (WMS): 

https://geoegl.msp.gouv.qc.ca/ws/mffpecofor.fcgi? 

 

C) It is also possible to download these products directly from the Données Québec website (the 
gouvernement du Québec collaborative, open data internet portal). To do this: 

1. Refer to the "Données Québec” LiDAR fact sheet. This fact sheet also contains other 
information pertaining to the use of these products, including metadata (year of 
acquisition, point density and presence of leaves). 
 

2. Directly access the FTP data directory, where data is categorized by map sheet: 
https://diffusion.mffp.gouv.qc.ca/public/Diffusion/DonneeGratuite/Foret/IMAGERIE/Pr
oduits_derives_LiDAR/. 
 

  

https://www.foretouverte.gouv.qc.ca/
https://www.donneesquebec.ca/recherche/fr/dataset/produits-derives-de-base-du-lidar
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4 RASTER DATA IN ARCGIS 

This section covers basic operations used to facilitate the use of LiDAR derived products with the 
commercial software package ArcGIS. While these techniques can all be used with other GIS 
software, the procedures will differ from one to another (operations for QGIS are described in 
Chapter 5). Also, take note that the proposed “.lyr” symbology will not work with other GIS 
applications. 

4.1 BASIC FEATURES 

4.1.1 View Raster Data 
Once you have downloaded the LiDAR derived products (see chapter 3), you can open the files in 
ArcGIS by clicking on the “Add Data” button. 

 

In the following window, select the “.tif” file of the map sheet you wish to view, or select the “.lyr” 
file to view the symbology proposed with the data (Note: MHC = CHM, MNT = DTM, 
MNT_Ombre = Hillshade and Pentes = Slopes). 
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The proposed symbology will appear if you selected a “.lyr” file. 

 

4.1.2  Change the Symbology and Select Classes 
To modify the proposed symbology, place the cursor over the layer name, right-click and select 
the layer’s properties. The following window will appear. In the “Symbology” tab, click on 
“Classified” to change the number of classes. Then click on “Classify …” to change the class break 
values. 
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The following window will open where you can change the class break values. 

 

To save the new symbology, place the cursor on the layer name, right-click and select “Save as 
layer file”. You can then import this new “.lyr” symbology using the “Import” icon, as shown on 
the following image. 
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4.1.3 Create a Transparent Layer of a DTM Combined With a Hillshade 
Combining a DTM and a Hillshade can be used to interpret certain terrain features. First, you must 
modify the DTM’s symbology. To do so, position the cursor on the layer name and right-click to 
select the layer’s properties.  

Next, in the “Symbology” tab, select the “Stretched” category and choose a color ramp. You can 
also import the DTM’s “.lyr” to apply the predefined symbology (see section 4.1.1). 
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Next, go to the “Display” tab of the layer’s properties window and apply a 50 % transparency.   

 

When you overlap the DTM with the Hillshade, interpretation of the two combined layers 
provides information about both altitude and terrain. 
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4.1.4 Create a Hillshade from a DTM 
The proposed Hillshade was designed with ArcGIS’s default azimuth value of 315°. In some cases, 
depending on the direction of the glaciers, it may be appropriate to generate a hillshade at 
another azimuth for the relief of certain terrain structures to stand out, such as eskers.  

To generate a new hillshade, you must add the DTM to ArcGIS. Next, open the image analysis 
window by clicking on “Windows” and then “Image analysis”. 

When the window appears, check the DTM to be edited. In the “Processing” section, select the 
desired colour gradient (black and white in the following example) and click on the “Hillshade” 
icon: 

 

 

 

The hillshade will appear in ArcGIS.  
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To change the azimuth of the hillshade, place the cursor on the name of the newly generated 
layer and right-click to select the layer’s properties. Select the “Functions” tab, place the cursor 
on the hillshade function, right-click and then click on “Properties”. 

 

The following window, in which you can change the azimuth and Z factor in the “Hillshade” tab, 
will appear. We recommend that the Z factor be set to 2. It is preferable to set the azimuth to a 
value perpendicular to the land structures to be detected, as shown in the two examples below, 
where the angle of 320° makes it possible to identify a steep slope, something that cannot be 
done using an angle of 270°. A southern azimuth angle (e.g. 180°) should not be used because the 
topography will be reversed, as in the third example below. 

 



  User’s Guide: Products Derived from LiDAR Data - 2nd edition 

Ministère des Forêts, de la Faune et des Parcs   14 

 

 

Example 1: Hillshade with a 270° azimuth and a Z factor of 2. 

 

Example 2: Hillshade with a 320° azimuth and a Z factor of 2. 

 

Example 3: Hillshade wtih a 180° azimuth (south) showing reversed topography. 

Steep slope  

Steep slope  
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4.1.5 Create a Slope Model 
To create a slope model, a DTM must be added to the map’s table of contents. Next, click on 
“Windows” in the toolbar and select “Image Analysis”. When the window opens, select the DTM 
on which you wish to work and then click the “Add a function” button (in yellow in the image 
below) in the “Processing” section. 
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A new window will open. Place the cursor on the DTM, then right-click and select “Insert 
Function”. Select “Slope Function” from the list of functions. 

 

A new window will open where you should select PERCENT_RISE as the output measure. Leave 
the Z factor at 1 and click on OK. 

 

Then click on OK in the “Function Template Editor” window, and you will obtain a black-and-white 
slope model. You can change the symbology (see section 4.1.2) or apply a “.lyr” file containing the 
desired symbology (see section 4.1.1 or next page). You can downlowd the proposed “.lyr” for 
slopes from the “Symbologie.zip” file at: 

https://diffusion.mffp.gouv.qc.ca/public/Diffusion/DonneeGratuite/Foret/IMAGERIE/Produits_d
erives_LiDAR/. 
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To change the symbology, right-click on the layer you have created and select “Properties” to 
open its properties. In the “Symbology” tab, click on the “Import” button (in yellow in the image 
below), then select the “.lyr” file containing the symbology (e.g. “Pentes_32I12NE.lyr”) and click 
on OK. 

 

This will give a slope layer with the desired symbology, similar to the image below. In the proposed 
symbology for slopes, the upper value of each class is included, e.g. the 0 to 3 % includes the value 
3.000000 %, and the 3 to 8 % class starts at 3.000001 % and includes the value 8.000000 %. 
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4.1.6 Assemble Several Rasters 
To assemble multiple raster images together, you can use the “Mosaic to New Raster” tool by 
clicking on “Data Management Tools > Raster > Raster Dataset > Mosaic To New Raster” in 
ArcToolbox. Assembly is best done using a limited number of map sheets. With more than 10 map 
sheets, the generated raster will probably be too large to use.   

 

 

1. Input Rasters:  Select the .tif images, not the .lyr files. 
2. Output Location: Select the file in which the new raster will be saved. 
3. Raster Dataset Name with Extension: Assign the name of the output raster with the .tif 

extension.   
4. Spatial Reference  for Raster (optional): Select the reference for one of the data layers.  
5. Pixel Type (optional): Select 8_BIT_UNSIGNED for a hillshade and 32_BIT_FLOAT for other 

products.   
6. Cell size: Select the desired resolution (1 m is used in this example).   
7. Number of Bands: Select 1. 
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8. Mosaic Operator (optional): Select “Maximum”, because the overlapping pixels are 
generally similar. However, other types of operators would have little impact on the 
result.   

9. Mosaic Colormap Mode (optional): Select “First”. 
 

4.1.7 Clip Raster Data in a Given Area 
To clip a raster, first select the raster to be clipped. Then select “Customize” > ”Toolbars” and 
“Draw”. Use the rectangle tool to create a rectangle for clipping.  
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Open the image analysis window by clicking on “Windows” > ”Image Analysis”. In the image 
analysis window, click on the “Clip” tool.  
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Lastly, right-click on the name of the clipped image and then on “Data > Export Data”. This will 
enable you to save the new clipped raster. 
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4.2 ADVANCED FEATURES 
Other products can be created from basic LiDAR derived products using territorial analysis. Both 
applications previously mentioned (ArcGIS and QGIS) offer tools that can be used to obtain 
contour lines, convert rasters to polygons, fill lakes, delimit drainage basins (watersheds), 
reclassify rasters, generate a focal CHM, generate a topographic wetness index, etc. 

4.2.1 Create Contour Lines 
Requires the 3D Analyst licence (see the licence-free process with QGIS in section 5.3.1). 

To create contour lines, you will need one or more DTMs for the region for which you want the 
contour lines. The DTMs should ideally be clipped (see section 4.1.7) or combined to obtain the 
desired area only, since this will increase processing speed. Once the area is ready, open 
ArcToolbox and select “3D Analyst Tools” > Raster-surface > Contour”. The following window will 
open. 

In the new window, select your “Input raster”, select the output location (“Output polyline 
features” field) and enter the required distance between each line in the “Contour interval” field. 

 

  



  User’s Guide: Products Derived from LiDAR Data - 2nd edition 

Ministère des Forêts, de la Faune et des Parcs   23 

This will give a result similar to the following image. 

 

The colour of the lines can be changed by right-clicking on the layer and selecting the “Symbology” 
tab of the “Layer Properties” window. Labels can also be displayed using the “Labels” tab in the 
“Layer Properties” window. Check “Label features in this layer” and select the “Label Field” you 
wish to display. 
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4.2.2 Reclassify Rasters 
It can be useful to reclassify rasters, among other things to convert a raster file into a vector layer. 
This operation requires the “Spatial Analyst” extension and is carried out using the Hillshade layer. 
First, the desired Hillshade must be added to the project’s table of contents. Next, open 
ArcToolbox and select “Spatial Analyst Tools > Reclass > Reclassify”.  The following window will 
open. 

Next, select the raster on which you wish to work and select “Value” in the “Reclass field”. To 
reclassify the values, click on the “Classify” button in the reclassification section. The list of values 
will then appear in the field on the left-hand side, and a predefined classification will be offered. 
You can change it as you wish. Once the classification values have been chosen, select a location 
for your output raster and click on OK. Your new raster will be added to your map’s table of 
contents. 

  

 

  

MNT_Ombre_22C04NE 

Value 
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4.2.3 Convert a Raster Image to Vector Format (Polygons) 
Converting a raster image to vector format allows LiDAR data to be used on certain types of GPS 
devices that are unable to read raster files. Please note that the process is very time-consuming, 
so make sure you have clipped the area you want (see la section 4.1.7) before starting the process. 
In addition, we recommend reclassifying the raster (see section 4.2.2) to avoid producing a 
polygon for each pixel, which would make the layer too big to use. 

To convert a raster, start by adding the raster you wish to convert to the project table of contents. 
Then, from Arc Toolbox, select “Conversion Tools > From Raster > Raster to Polygon”. Next, select 
the desired input raster, select a location for the output polygon file, and click on OK. 
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4.2.4 Create a Focal CHM 
A focal CHM can be created from a CHM. The focal CHM better indicates the maximum canopy 
height value for coniferous trees, making it easier to interpret stand height. However, the focal 
CHM artificially expands canopy diameter and thereby significantly overestimates cover density. 

To create a focal CHM, start by adding the desired CHM to the project table of contents. Next, 
in Arc Toolbox, select “Spatial Analyst Tools > Neighborhood > Focal Statistics”. The following 
window will open. In this new window, select the CHM you want as the input raster and select a 
location for your output raster. Next, select “Circle” in the “Neigborhood” drop-down menu and 
“MAXIMUM” in the “Statistics type (optional)” drop-down menu. For a CHM of a coniferous or 
mixed forest, you should test several radius values, but the value 3 generally gives good results 
and provides a better view of the maximum coniferous stem value. 

 

 

After processing, you will obtain a raster similar to the following image.  

Standard CHM      Focal CHM 
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4.2.5 Topographic Wetness Index 
The topographic wetness index (TWI) is used to assess the ground’s capacity to retain moisture. 
It takes into account water accumulation and slopes at a specific location. 
 
You must first download the SAGA file from: https://sourceforge.net/projects/saga-gis/. 

 

Next, install the necessary SAGA toolboxes. To do this, right-click on “Arc Toolbox” and select 
“Add a toolbox”. Then select the folder in which you saved your SAGA file (it must be unzipped 
first). In the SAGA file, select “ArcSAGA Toolboxes” and install the “Terrain Analysis - 
Preprocessing” and “Terrain Analysis - Hydrology” toolboxes. 

 

Once the toolboxes have been installed, the first process is to fill surface depressions. To do this, 
select “Preprocessing > Fill sink XXL”. In the new window, select the DTM you want in the “DEM” 

https://sourceforge.net/projects/saga-gis/
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field, then select the location of the output file (“Filled DEM” field) and enter 0.01 as 
the “Minimum Slope [Degree] (optional)”. 

 

 

Next, open “Hydrology > SAGA 
Wetness Index”. The window on the 
right will be displayed. Select the 
DTM resulting from the first process 
(Filled DEM) in the “Elevation” field. 
Next, select a location for the output 
files, namely “Catchment Area”, 
“Catchment Slope”, “Modified 
Catchment Area” and “Topographic 
Wetness Index”. Lastly, select “total 
catchment area” for “Type of Area” 
and “local slope” for “Type of Slope”. 
The other settings should be default 
values. 

This will give you the TWI in raster 
format. You can then change the 
symbology if you want (see 
section 4.1.2). 

For more information about this 
method, see the following video on 
YouTube, produced by Sylvain Jutras 
and his team from Université Laval: 

https://www.youtube.com/watch?v=V2hTDlhwo7s. 

https://www.youtube.com/watch?v=V2hTDlhwo7s
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5 RASTER DATA IN QGIS  

This section covers basic operations for an easy use of LiDAR derived products in the open source 
software QGIS. These techniques work in other GIS applications, however the methods used differ 
from one to another. Also, take note that the suggested “.qml” symbologies will not work with 
other GIS applications. 

5.1 DOWNLOAD AND INSTALL THE APPLICATION 
QGIS is a free and open source geographic information system. It is user-friendly and designed for 
the general public. It can be downloaded from the QGIS 
website (https://qgis.org/en/site/index.html) and installed on multiple workstations free of 
charge. The application is created and constantly upgraded thanks to an extensive network of 
volunteers and user donations. 

 

  

https://qgis.org/en/site/index.html
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5.2 BASIC FEATURES 

5.2.1 View Raster Data and Download Predefined Symbologies 
Once you have installed QGIS and downloaded the LiDAR derived products (see chapter 3), you 
can open the files by clicking on the “Layer” tab, then “Add Layer” and “Add Raster Layer…”. 
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Once the following window opens, click on the “…” to select the “.tif” file of the map sheet you 
wish to view, and click on “Add” (Note: MHC = CHM, MNT = DTM, MNT_Ombre = Hillshade and 
Pentes = Slopes). 
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Once the file opens, a black-and-white layer will appear on the screen.  

 

The predefined symbologies are not included in the “.tif” file. Separate “.qml” files must be 
downloaded (the “.lyr” format does not work in QGIS). These symbologies are in the 
Symbologie.zip file at:  
 
https://diffusion.mffp.gouv.qc.ca/public/Diffusion/DonneeGratuite/Foret/IMAGERIE/Produits_d
erives_LiDAR/. 
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To display the downloaded symbologies in QGIS, place the cursor over the layer name, right-click 
and select “Properties” to display the layer properties. The following window will appear. 

To upload the desired “.qml” file, select the “Symbology” tab and then “Load Style” from the 
“Style” drop-down menu. 

 

The proposed symbology will be applied to the chosen layer. 
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5.2.2 Change the Symbology and Select Classes 
The proposed symbology can be changed to suit your needs. To do this, select the layer’s 
properties (right-click on the layer name and select “Properties”). 

Using the “Symbology” tab in this window, you can change the limit values and colours associated 
to each class interval by double-clicking on the colour box. You can also use the “Mode” drop-
down menu to select different types of class intervals (“Continuous”, “Equal Interval”, and 
“Quantile”). Finally, you can change the number of classes by selecting the “+” and “-” buttons 
next to “Classify”.  
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5.2.3 Create a Transparent Layer of a DTM combined with a Hillshade  
As mentioned in section 4.1.3, a combination of a DTM and a Hillshade can be used to interpret 
certain terrain features. First, start by adding the DTM and Hillshade to QGIS and then load the 
“.qml” symbology for the DTM, as described in section 5.2.2. 

Next, in the DTM’s “Layer Properties” window (right-click on the layer name, select “Properties”), 
select the “Transparency” tab and reduce “Global opacity” to 50 %.   

 

Finally, overlap the DTM with the Hillshade. The combination of these two layers provides 
information on both altitude and terrain. 
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5.2.4 Create a Hillshade from a DTM 
The proposed Hillshade was designed using ArcGIS’s default azimuth of 315°. In some cases, 
depending on the direction of the glaciers, it may be appropriate to generate a hillshade at 
another azimuth for the relief of certain terrain structures to stand out, such as eskers.  

To generate a hillshade in QGIS, you must add the DTM to your project. Next, click on “Processing” 
in the main toolbar and on “Toolbox”.  

 

The “Processing Toolbox” will then appear. Click on “Raster terrain analysis” and then on 
“Hillshade”. 
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In the above “Hillshade” window, select your DTM as “Elevation layer” and identify the “Z factor” 
and desired “Azimuth” for the hillshade you want to create. The standard azimuth (horizontal 
angle) is 315° and the recommended Z factor is 2. We also recommend a vertical angle of 40°. 
Lastly, if you wish to save the final layer, select a file location and name in the “Hillshade” field. 
Otherwise, the layer created will be lost once you close the project. Click on “Run in Background”. 

As mentioned in section 4.1.4, it is preferable to set the azimuth at a value perpendicular to the 
land structures to be detected, and to avoid using a southern azimuth angle (e.g. 180°) which will 
reverse the topography.  

This tool will produce a result similar to the following image. The small sign next to the layer name 
indicates that this is a temporary layer because no output location was given. To save the file 
permanently, right-click on the layer name, then on “Export” and “Save as”. In the new window, 
click on “Scroll” to the right of the “File name” field and select a location and layer name. Before 
closing a project, it is a good idea to check if any layers you wish to save for further use have this 
symbol. 

  

  

Temporary layer 
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5.2.5 Create a Slope Model 
To create a slope model using QGIS, you must start by adding a DTM to your project. Next, in 
“Processing Toolbox” (“Main toolbar” > “Processing” > “Toolbox”), click on “Raster terrain 
analysis” and then on “Slope”.  

 

The following window will be displayed. In this window, select your DTM as your elevation layer, 
leave the Z factor at 1 and select, if desired, an output location in the “Slope” field. If not, the 
created layer will be temporary, and will disappear once the project is closed. Lastly, click on 
“Run in Background”. 
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The new raster file will be in black-and-white.  

  

To obtain the predefined symbology, you will need to load it by following the steps described in 
section 5.2.2. Select the “Pente.qml” file. This will result in an image similar to the one below. 
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5.2.6 Assemble Several Rasters 
To assemble multiple raster images together, click on “Raster” in the main toolbar and then 
“Miscellaneous” and select “Merge”. 

 

The following window will open. Assembly is best done using a limited number of sheets. Above 
10 sheets, the generated raster will probably be too large to use. 

In this window, select the rasters to be assembled as input layers and select the output location 
in the “Merged” field. Otherwise, the layer you create will be temporary, and will disappear once 
the project is closed. Next click on “Run in Background”.  
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5.2.7 Clip Raster Data in a Given Sector 
To clip a raster, first display the raster to be clipped. Then click on “Raster” in the main toolbar 
and select “Extraction” then “Clip Raster by Extent”.  

 

The following window will open. The input layer is the raster you wish to clip. For the size of the 
clip, click on the “…” next to the “Clipping extent” field. Next, select “Select extent on canvas” and 
use the cursor to select the area to be clipped on your raster. Lastly, select the location for the 
output file in the “Clipped (extent)” field. Otherwise, the created layer will be temporary and will 
be lost when the project is closed. Lastly, click on “Run in Background”. 
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5.3 ADVANCED FEATURES 
Other products can be created from basic LiDAR derived products using territorial analysis. Both 
applications previously mentioned (ArcGIS and QGIS) offer tools that can be used to generate 
contour lines, convert rasters to polygons, fill lakes, delimit drainage basins (watersheds), 
reclassify rasters, generate a focal CHM, generate a topographic wetness index, etc. 

5.3.1 Create Contour Lines 
To create contour lines, you will need one or more DTMs of the region for which you want the 
contour lines. The DTMs should ideally be clipped or combined to obtain the desired area only, 
since this will increase processing speed. Once the area is ready, click on “Raster” in the main 
toolbar and select “Contour” in the “Extraction” tab.  

 

The following window will open. In this window, select the raster of your choice as the input layer 
and select a location for your output file (the “Contours” field). Use the “Interval between contour 
lines” field to choose the desired interval between the contour lines, then click on “Run in 
Background”. A file containing the contour lines will be added to your table of contents. 
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Thereafter, in the “Layer Properties” window (right-click on the layer title > “Properties”), you can 
change the colour of the contour lines (“Symbology” tab in the side menu) and the altitude can 
be shown by displaying the labels. To do so, click on “Labels” in the side menu, then choose “Single 
labels”, followed by “ELEV” in the drop-down menu “Label with”. Next, click on “Placement” and 
select “Curved” to make the labels follow the lines. 

 

 



  User’s Guide: Products Derived from LiDAR Data - 2nd edition 

Ministère des Forêts, de la Faune et des Parcs   45 

5.3.2 Reclassify Rasters 
To reclassify rasters in QGIS, you will need to use the GRASS GIS extension that is usually 
downloaded at the same time as the QGIS application. It is important to open the version of the 
application that includes this extension.  

 

If you do not have the extension, you can download it here: https://grass.osgeo.org/download/.  

Once the application has been downloaded and the correct QGIS version is open, you can access 
the GRASS toolbox in “Processing Toolbox” (main toolbar >“Processing” > “Toolbox”). Otherwise, 
click on “Options” in the “Processing Toolbox” taskbar. 

  

  

Options 

https://grass.osgeo.org/download/
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In the new window, select the “Processing” tab, followed by “Providers” and “GRASS”. Make sure 
the “Activate” field is checked. 

 

 

In the GRASS toolbox, click on Raster (r.*) and then on “r.reclass”. The following window will 
open.  

In this window, select the input raster in the “Input raster layer” field. You must also indicate the 
reclassification rules, which can be applied either by importing a document containing the 
reclassification rules in the field “File containing reclass rules” or by entering them manually in 
the “Reclass rules text” section. Lastly, in the “Reclassified” field, select the location for your 
output file, so that it is saved and click on “Run”. 
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Your raster, with the new classification criteria, will be displayed on the screen. In the above 
example, the DTM values will be reclassified into four categories, based on altitude. 
 

 

5.3.3 Convert a Raster Image to Vector Format (Polygons) 
Converting a raster image to vector format allows LiDAR data to be used with certain types of GPS 
devices that are unable to read raster files. Firstly, make sure that the area of interest has been 
clipped as this is a very time-consuming procedure (see section 5.2.7). In addition, we recommend 
reclassifying the raster (see section 5.3.2) so as to avoid producing a polygon for each pixel, which 
would make the layer too big to use. 
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To convert a raster to polygons in QGIS, click on “Raster” in the main toolbar, then select 
“Conversion” and click on “Polygonize (Raster to Vector)”.  
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The following window will open. The “Input layer” is the raster to be converted to polygons. In 
the “Vectorized” field, select a location to save the layer permanently. Click on “Run in 
Background”. You will obtain a file similar to the image shown below.  
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To open the new layer’s attribute table, right-click on the layer title and on “Open Attribute 
Table”.  

  

If you want the table to be included in your project window, click on “Settings” in the main toolbar, 
and then on “Options”. In the new window, select “Data Sources” and check “Open attribute table 
in a dock window”. 
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5.3.4 Create a Focal CHM 
A focal CHM can be created from a CHM. The focal CHM better indicates the maximum canopy 
height value for coniferous trees, making it easier to interpret stand height. However, the focal 
CHM artificially expands canopy diameter and thereby significantly overestimates cover density. 

To create a focal CHM, start by adding the desired CHM to the project’s table of contents. Next, 
in “Processing Toolbox” (main toolbar > “Processing” > “Toolbox”), select the GRASS box (see 
section 5.3.2 to install the GRASS extension if necessary), then click on “Raster (r.*)” and 
on “r.neighbors”.  

The following window will appear. First, select the CHM you want to use as the input raster (“Input 
raster layer”). Next, select “maximum” in the “Neighborhood operation” field, enter “3” in 
“Neighborhood size” and check “Use circular neighborhood”. Lastly, select a file location to save 
your output focal CHM (the “Neighbors” field) and click on “Run”. The circular option may not be 
available in some versions of QGIS, meaning that you will obtain a focal CHM with square 
canopies.  
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After processing, you will obtain a raster similar to the following image.  

Standard CHM      Focal CHM 

 

 

5.3.5 Topographic Wetness Index 
Another tool that can be created using LiDAR products and QGIS is the topographic wetness index 
(TWI), which is used to view areas having a potential for high moisture retention capacity. To do 
so, you must first have installed the “SAGA” extension.  

The SAGA file can be downloaded here: https://sourceforge.net/projects/saga-gis/. 

 

The SAGA toolbox can be found in “Processing Toolbox” (main toolbar > “Processing” > 
“Toolbox”). If not, click on “Options” in the “Processing Toolbox” taskbar. 

The first step in creating a TWI is to fill depressions in the digital terrain model. To do this, select 
“Preprocessing > Fill sink XXL” (see section 4.2.5). 

 

  

https://sourceforge.net/projects/saga-gis/
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Next, in the “Processing Toolbox” taskbar (main toolbar > “Processing” > “Toolbox”), select 
“SAGA”, then “Terrain Analysis-hydrology” and finally, “SAGA Wetness Index”.  

The following window will open. In this window, you must use the filled DTM raster completed in 
the previous step in the “Elevation” field. Next, select “absolute catchment area” in the “Type of 
area” field, and “local slope” in the “Type of slope” field. Lastly, you must select locations to save 
the four output files (“Catchment Area”, “Catchment Slope”, “Modified Catchment Area”, and 
“Topographic Wetness Index”). This will generate a TWI similar to the following image, once the 
colours have been changed. Please note that this process is very long and modelling should be 
limited to the area of interest. 
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6 CONCLUSION  

This document is intended to help with the use of products derived from LiDAR data. For 
comments or to suggest improvements, please contact the Direction des inventaires forestiers: 

Inventaires.forestiers@mffp.gouv.qc.ca 

 

mailto:Inventaires.forestiers@mffp.gouv.qc.ca
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